My Tractor Forum banner
1 - 4 of 4 Posts

·
Registered
Joined
·
2,373 Posts
Discussion Starter · #1 ·
I have several Echo straight shaft string trimmers. I put the heads that you line up the hole and stick the line through and wind it on. Grabbed my favorite trimmer and put new line on, in 30 seconds, the line rewound inside the head. Took it apart and 30 seconds later rewound again. Is this a common problem. Those heads are about $40 and don't want to replace it if it's a common problem?
 

·
Registered
Joined
·
4,467 Posts
Is it possible that the string can be wound in the wrong direction or does it only allow winding in one direction ?
I still wind mine by hand so I know which way to wind in on the drum, but have seen videos of the ones you have and they look GREAT, if they work.
 

·
Registered
Joined
·
1,255 Posts
Sounds as if you have the inner spool wrong way 'round/flipped over. I have the same head and other than excessive feeding sometimes, it works great.....Mike
 

·
Registered
Joined
·
2,373 Posts
Discussion Starter · #4 ·
I think I figured it out, not the spool or the way it was wrapped. I bought a new one and the first thing I noticed was the string was much thicker. It runs .095 line. My wife gave me a big spool of line a friend gave her. We used it on the old trimmer that has the spool you pull out and wind. It takes .080. I'm going to take that spool off the older machine and put the used one I took off my machine, on it. I have a new spool of .095 in my tool box. I'll give it a try and get back with the results. I really like the new spool you just stick the line through and wind it up. I take three stretches of my arms, 6, 12, 18'. It seems to hold 18' no problem.
 
1 - 4 of 4 Posts
Top