My Tractor Forum banner

1 - 4 of 4 Posts

Registered
Joined
59 Posts
Discussion Starter #1
I recently acquired a echo es-1000. I cleaned and rebuilt the carb and replaced the primer and installed new fuel lines and the fuel tank grommet. I press the primer bulb and im getting air pushed out the return line into the fuel tank. But the pickup line with the filter is not sucking fuel up.. I recleaned the carb and blew air through all the passages i could fine. Still having the same issue. What else could i try before i buy another carb. Would you even fix this blower? It did start and run good when i put some gas down the carb.

Thanks
 

Moderator
Joined
2,792 Posts
Are you sure you connected the fuel lines correctly?....should this one be going to the carb?
Although, ...I did recently get a "carburetor" for an old Briggs that is part of the fuel tank...the old one did not have a primer bulb...the new one did....it worked fine the first time...then a week later it did not work...the vendor sent me another one....same thing happened, worked fine the first time and that was it...I would definitely try fixing it
 

Registered
Joined
282 Posts
You can try putting a clear fuel pickup line in a jar of fuel and see if purge bulb moves fuel. If not, OnCarb purge assembly has failed. This carb is probably NLA. Easiest is find a replacement carb that fits re: throttle link, choke link, impulse hole. Some adaptation may be necessary - I've drilled new throttle rod holes and used a different choke rod - like a coat hanger inserted in a dowel. Jury rigging can work.
Search ebay "Trimmer Carburetor" and start looking and comparing.
 

LBAD Victim
Joined
959 Posts
It could also be the check valve, which is the base the primer is attached to. It could also be the wrong diameter fuel line letting air through.
 
1 - 4 of 4 Posts
Top