My Tractor Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
365 Posts
Discussion Starter #1
Does any one have pictures of a 54" deck on a GT5000 or DGT6000? I'm getting all the pieces together on the DGT I just bought and the deck sits way to the left. For those that know what the setup looks like, the left side "quick" mounting bracket is tight to the hanger, and the right side is so far away the "quick" bracket actually fell out when I tried mowing with it.

Everything appears to be on the tractor correct, the deck just wants to ride so far over.

Any thoughts? I can get some pictures tomorrow. Thanks!
 

·
Registered
Joined
·
2 Posts
Look at the front bracket that goes from the deck to the frame it may be upside down, I did that on my DGT and it moves the deck over so that it wont fit properly. Hope this helps.
 

·
Registered
Joined
·
269 Posts
I just installed a 54" deck on my GT5000 earlier in the year. I should have some pics I can share with you. The 54" deck came off of DGT6000. I remember I had to completely change out the mounting brackets from the frame. I also had to drill a couple new holes to mount the anti-sway bar. Take some pics of what you have and I can tell you what you need to adjust.
 

·
Registered
Joined
·
365 Posts
Discussion Starter #4
Awesome, I'll grab some pictures.

Thanks!
 

·
Registered
Joined
·
365 Posts
Discussion Starter #7
No word back. I assume you fixed the problem. Good deal. Happy mowing.
Well... sorta. I found a temporary solution, but would like to figure out the issue and fix it right. Its been a hectic week but I grabbed some pictures last night.

Here is the "good" side-



Here is the "bad" side. Note, this is right after I put the deck on so it doesnt look as bad. If I mow for a bit, the deck works further away from the bracket on this side-



My temporary solution is to put a 1/2" nut between the deck and mounting bracket on the "tight" side which pulls in the loose side.

Thanks for sticking with my post.
 

·
Registered
Joined
·
269 Posts
Here's some pics from my ride. I hope this helps. Looking at what you got, it's hard to see exactly what the problem is. Maybe take one or two from right in front of the rear tires.
 

Attachments

1 - 8 of 8 Posts
Top