My Tractor Forum banner

1 - 8 of 8 Posts

Registered
Joined
2 Posts
Discussion Starter #1
I just purchased my Cub Cadet XT1 two days ago from Home Depot. It was still crated and I assembled myself.
Mower was used to cut about an acre, cleaned and stored under a shed with a cover.
New gas can and fresh gas used from the start. Air filter is clean.
Went out today to do more mowing and when starting, the engine revs to excessive rpm and acts like the governor is stuck.
Mower starts to shake like it will fly to pieces. Only let it run for a few seconds. Worried it will throw a rod.

I know the XT1 has the "Intellipower" feature. I tried starting with the knob in different positions with the same result.
Contacted Cub Cadet warranty and they had no solution other than take to Authorized Repair Center. (Still waiting on e-mail of Service Center in my area.)
The mower is three days old, should I just take it back to Home Depot for replacement, refund or HOPE for a solution at Service Center?
Anyone else had this issue?
 

Moderator
Joined
2,459 Posts
Welcome to MTF Jim. 馃嵒

You're throttling down after start, right?

If it won't throttle down and the problem's not immediately obvious I'd take it back and get a different one.
 

Gravely1964
Joined
3,930 Posts
Have not had to play with an knob one yet anyhow. I said it so im sure tomorrow now lol. Its got to be something dumb that changed in between. Best advice I can give is manually work by hand and see if the throttle linkage moves by hand or not. Since I haven't had to mess with one yet even the cub grease monkey is not much help
 

Registered
Joined
2 Posts
Discussion Starter #5
Thanks for the replies.

I am a computer tech. When they don't work we "Reboot" them.
I disconnected the battery cable for about 10 minutes then re-connected. This should reset the computer controls for the "Intellipower" sensors.
The mower started up with high rpm, then settled back to a normal rpm after about 3 seconds.
The throttle knob is now working correctly moving between idle, transport, cut and power cut .

Hope this helps someone else.
 

Registered
Joined
425 Posts
Congrats. One of those problems that get solved quickly but I always wonder what occurred afterward
 

Moderator
Joined
2,459 Posts
Might have picked up some static in shipping... did the machine come with the battery hooked up?
 
1 - 8 of 8 Posts
Top