My Tractor Forum banner

Crazy X585 starting problem

9921 Views 9 Replies 6 Participants Last post by  davidg
Hi there- new to this forum, but member of others and know all too well how helpful these places can be.
Here is the scenario:
I was completing basic service for an X585. Change oil and filter. Replace spark plugs. Service air cleaner.
Remove black screen side panels from the steering column console and blow out interior space with compressed air. Unfasten oil/transmission cooler from the engine radiator and clean it and the engine radiator with compressed air.
Re-attach the tranny cooler (now when I say reattach, I mean place it back up against the radiator and flip the little spring tabs back into the lock position-no hoses were disconnected for this process).
In the process of blowing out the radiators and the entire area inside the steering column console, I did have to jostle around the wiring harness a bit to access debris lodged towards the middle of the compartment.

Now, when I attempt to start the engine, the key switch engages the starter immediately when moved to the "run" position as opposed to merely priming the fuel pump and illuminating the instrument cluster.
Again, turn the key to "run" (not "start" position) and the starter engages immediately and stays engaged when the engine starts.

This is the most puzzling thing I have ever experienced. The answer has to be simple because I DIDN"T DO ANYTHING! (exasperation, not shouting)
I did check that all connections were intact, and as far as I can tell, they are. I did replace all 3 relays in the hope that one had gone bad from the ever-so-slight jostling they received when I was cleaning out the area.
BTW-if I pull the hot lead off the solenoid and turn the key to the run position, the usual normal stuff happens-lights illuminate and fuel pump primes. Of course then the unit won't start if I turn the key to the start position.

So, here I am looking to those with more experience to see if anyone has ever encountered a similar situation.
I am completely baffled again because I didn't so anything to warrant such a weird problem. It seems like I must have knocked something loose or grounded something out somehow, but for the life of me I can't see what it might be.
Any insight will be greatly appreciated.
See less See more
1 - 3 of 10 Posts
If , when you turn the key to the "on" position and the starter engages, you must have a short or crossed connection. I'd begin the search by unplugging the connector from the starter switch and make sure none of the pins inside the connector are touching. Trace the wire bundle from the switch until it exits the area between the instrument panel and radiator, and make sure any of the other connectors you find haven been twisted or pulled loose.

This sounds like an easy fix, but maybe difficult to find the cause. If you were pushing the wiring bundles around, something probably got worked loose, or twisted. I have a 748, so I'm familiar with what it looks like in there. I gave up trying to work my trans cooler out of the space, I was able to clean it well enough by just unfastening it from the radiator and blowing compressed air through it and the radiator.
PS, the ignition switch is like nothing I have ever seen before. Not a multi-pin connector type, but a hard soldered affair with a bit of circuit board attached to the back of the switch. Then, those wires are soldered to another circuit board from which eminate a multitude of other wires.
I mean, I have never seen wiring like this in outdoor power equipment. It looks like the wiring harness for a truck!
Sounds like another example of "They don't make them like they used to". I'll admit, I haven't dug far enough under the instrument panel to actually see the switch connection. This is a bit of surprise, I sort of expected the switch to have three or four terminals with a single connector.

This complicates things, as it will be much more difficult to trace the wiring without a voltmeter (or even with one), so find the location of the short. If it lies within the circuit boards, you're screwed. It may be that one of them has a small crack and that has something to do with it. I'm going to take a look at how mine is made, if I see anything that suggests something to check out, I'll post it here. In the meantime, good luck.
I'm glad you got it worked out, or that it worked itself out. I hate electrical problems, sometimes there is just no way to figure it out without pulling everything out where you can get at it.

After your last post, I went out and looked at my switch, it is nothing like you describe yours to be. Mine is kind of buried behind the two rods that go from the hydraulic controls down to the valves, but it has a four-pin connector on back and NO circuit boards. My relays are on the other side of the steering column from the ignition switch, and the only other thing not inside the sealed instrument panel is the fuse panel, which sits on the left side of the steering column below where the relays are.
1 - 3 of 10 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.