My Tractor Forum banner

Craftsman Weedwacker 4 cycle 30cc Bogging

2395 Views 4 Replies 4 Participants Last post by  PA318Guy
I've got a 2013 Craftsman Weedwacker 4 cycle 30cc trimmer that someone gave me that is bogging down when you give it throttle, It will die. Wouldn't run at all when I first got it. He was tired of messing with it. I went thru the carburetor and used carb cleaner on it with pressurized air, replaced the metering diaphragm, replaced the fuel lines and purge bulb. Starts right up on full throttle with full choke position 3, runs pretty good in half choke position 2 but on choke off position 1 idles fine but bogs right down with throttle. This is a walbro WYLA 3 carb with external bulb and does NOT have the low and high speed adjustment screws. Only adjustment is the idle speed screw on the throttle. So what should I be looking for now? Air leak maybe on gaskets. Maybe replace fuel pump diaphragm? Replace the whole carb with a new one $12. Maybe try and adjust the needle lever using the needle level tool? Appreciate any suggestions.
1 - 5 of 5 Posts
Welcome to the forums, glad to have you at MTF. 馃嵒

I have about a 50/50 success rate rebuilding Walbros... sometimes it just doesn't take.

If you've eliminated the possibility of bad fuel lines or other mischief I'd put a new carb on at this point, save frustration and get on with it.
  • Like
Reactions: lgosnell
Welcome to the forums, glad to have you at MTF. 馃嵒

I have about a 50/50 success rate rebuilding Walbros... sometimes it just doesn't take.

If you've eliminated the possibility of bad fuel lines or other mischief I'd put a new carb on at this point, save frustration and get on with it.
I may try and run the idle speed up higher right below where clutch would engage and see if the bogging issue improves, if not I'll take the carb back off and go thru it again. Or the $12 carb is also an option at this point.
I may try and run the idle speed up higher right below where clutch would engage and see if the bogging issue improves, if not I'll take the carb back off and go thru it again. Or the $12 carb is also an option at this point.
I have already tried the new carb and fuel lines. Ended up having to reuse one old line because the replacement was too loose.

It starts fine, but when I give it full throttle it wavers on RPM and will eventually quit on me. Any other ideas?
]
I have already tried the new carb and fuel lines. Ended up having to reuse one old line because the replacement was too loose.

It starts fine, but when I give it full throttle it wavers on RPM and will eventually quit on me. Any other ideas?
]
Welcome to MTF! You replied to a two year old thread, you may not get a response. I recommend starting your own thread on the problem in the appropriate forum. There is lots of info here and great members to help, enjoy the site! Here is some site navigation assistance in case you need it:

Font Parallel Technology Slope Screenshot
1 - 5 of 5 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top