My Tractor Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
I just recently bought a 646lbh front loader and backhoe work great moves well on flat surface but uphill or pushing has no power. My friend thinks it is the Hydraulic drive motor (c14655) which is no longer available. Is there a different one I can use? Rebuild kit? or could it be something else that is wrong with it?
 

·
Moderator
Joined
·
4,878 Posts
Welcome to My Tractor Forum...did you check fluid level and filter?...could be low fluid level of clogged up filter
 

·
Registered
Joined
·
2 Posts
Discussion Starter #3
My nephew is the one working on it and he said he made sure fluid was correct and filter not clogged. I also wanted to note that it doesn't have drive power in both forwards and reverse. I am not sure if he did a pressure test but he is a hydraulic mechanic and he is the one who diagnosed it as the drive motor which doesn't seem to be available any more. Is there a replacement like does the case 446 work they look the same.
 

·
Registered
Joined
·
235 Posts
My nephew is the one working on it and he said he made sure fluid was correct and filter not clogged. I also wanted to note that it doesn't have drive power in both forwards and reverse. I am not sure if he did a pressure test but he is a hydraulic mechanic and he is the one who diagnosed it as the drive motor which doesn't seem to be available any more. Is there a replacement like does the case 446 work they look the same.
Call Dan he may be able to help you with a used motor 810-348-6311
 
1 - 6 of 6 Posts
Top