My Tractor Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
So I got home excited about my new purchase yesterday and put the battery on charge. The previous owner had it running but it died often because it wouldn't hold a charge.
After charging it yesterday, it cranked up but I let it die. Then it started making a grinding noise and wouldn't turn over.
I'm working today so it will be on charge all day and I'll try again.
Any ideas?
It is original with a 16hp Onan twin cylinder. Maybe a '72
I hope I am posting in the right ared!!!
Thanks
 

·
jackthebaptist
Joined
·
196 Posts
Sounds like the solenoid is not engaging the starter drive all the way. Did you mean you had it running? I would probably pull the starter and check for damaged teeth on the flywheel and starter drive. Regards; Jack
 

·
Registered
Joined
·
4 Posts
Discussion Starter #4
Thanks for the advice. I spent all day Saturday thinking about it while working a 12 hour shift and concluded I needed to pull the starter to inspect.
After what the seller told me as to his experience with it, I also left it on charge all day.
When I got home from work it started first try with little effort and has been running fine since.
It does smoke some and I'm wondering how hard it is to get this 16hp Onan rebuilt. I was told it is a '72. It is part yellow and part red if that helps.
Otherwise, everything seems to function as it should.
Thanks,
Donny
 

·
Registered
Joined
·
940 Posts
Do you know how to check the charging system

Nice thing about the CCK engines they usually have a big oil pan so you dont need to worry about the oil for awhile
 
1 - 5 of 5 Posts
Top