My Tractor Forum banner

1 - 6 of 6 Posts

·
Addicted To Tractors
Joined
·
194 Posts
Discussion Starter · #1 ·
I have a 77 briggs and stratton model 19 on my massey furguson MF85. The motor runs very hot. It did have a massive mouse nest under the shroud but i cleaned it all out. theres is good oil but when it runs very hot it will die like it runs out of fuel. I thought it was the coil so i bought a solid state coil and its still doing it. it will start after it has cooled for a couple of hours. when i am cranking it makes some pop pop pop sounds before it actually fires. What is wrong here, could it be so hot that the gas is boiling and not burning it?
 

·
Master Service Technician
Joined
·
748 Posts
Is your muffler turning cherry red? Running hot is a lean fuel condition if all the cooling fins are clean.

If your muffler is turning cherry red, you need to check your flywheel key. It may be partially sheared.
 

·
Registered
Joined
·
5,304 Posts
Check the valve clearance. It might be tightening up a bit too much when it gets to operating temperature. Or you could have a valve guide that is a bit too tight, causing the valve to hang or close a bit too slowly. I have a Sears that I was given that would not re-start when it got hot. Cleaned up the valve seats, and ground the tip of the valve stem a bit and PBT. Fired right off, with more power than I had ever seen before. Valve clearance measurement was not done because I was too ignorant at the time to know that stuff was out here on the web. Mk I mod 0 eyeball worked enough for me.
tom
 

·
4K Poster!!!
Joined
·
4,504 Posts
Did you clean all of the fins out? There are some passages around the cylinder and valve gallery that need to be clean so that air can get through. Just removing the mouse nest from the shroud is not enough.
 

·
Addicted To Tractors
Joined
·
194 Posts
Discussion Starter · #5 ·
Did you clean all of the fins out? There are some passages around the cylinder and valve gallery that need to be clean so that air can get through. Just removing the mouse nest from the shroud is not enough.
yes cleaned everything. And No DTLMG, i replaced the flywheel key because it was sheared when i got it i think the motor hasnt run in probably cause nobody could get it unsheared. I also unbolted the muffler partially thinking it could have been clogged up but nope
 

·
20,000 +posts!
Joined
·
20,959 Posts
It could be the timing is off--with points you can vary the gap to alter the timing,but it isn't adjustible with a electronic coil..I'd look for a lean condition ,if the mixture is lean it'll run real hot..
Remember,when its 90-100 degrees out,any air cooled engine wil run very hot,air that hot to start with can only "cool" so much!..
 
1 - 6 of 6 Posts
Top