My Tractor Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
396 Posts
Discussion Starter · #1 ·
I have an x300 with a 44inch blower. I was looking the blower over and noticed the spout cable is stuck (the one that controls the direction up/down). I can't even get it turn to unlock. Has anyone had this issue? I figured I would ask before I go prodding at it too much.

Thanks,
-Tom
 

·
Registered
Joined
·
42 Posts
Have you figured this one out yet? I am going to get one for my X320 this weekend. Probably something I should look out for. Let me know if you found a solution.

:greendr:
 

·
Super Moderator
Joined
·
35,782 Posts
Any cable in sheathing where salt is at should be regularly lubricated (think parking brake cables on your car) or they will rust and stick. I would get some PB Blaster or WD 40 working its way down through the cable. (hang the cable up and then spray at the top so it drains through) Then work the cable, once it breaks loose then I would use regular 3 in 1 or motor oil in it for a final lubrication.
 

·
Registered
Joined
·
396 Posts
Discussion Starter · #4 ·
I did finally free it up, it required holding the cylinder in a vice, and holding the shaft with vice grips. Then a hitting it with a hammer quite a bit. The entire shaft was dark with corrosion. I got it out all the way, buffed the rust off the shaft and applied chainsaw bar lube to the shaft. I would say it just needs to be checked and oiled once in a while to prevent this. I don't know how long it was like that, since I bought it that way!

X320: I would lubricate it up front if it looks at all dry.

-Tom
 

·
Registered
Joined
·
396 Posts
Discussion Starter · #6 ·
Me too, I don't even want to know how much that assembly costs!
 

·
MTF Tractor Nut
Joined
·
4,455 Posts
Me too, I don't even want to know how much that assembly costs!
Probably more than it should... Glad to hear you got it fixed!
 
1 - 7 of 7 Posts
Top