My Tractor Forum banner
1 - 2 of 2 Posts

·
Registered
Joined
·
393 Posts
Discussion Starter · #1 ·
I have question maybe someone will be able to help me with on this new to me chipper. But first, Let me tell a short story.

So I was looking for an "economical" chipper solution. Started looking at stand alone units sold at BBS's and wound up with a LiL Mac that a friend of mine gave me. With a lil work at the local small engine guy, we had that running. And it was a fine little machine,,,, for what it was. But as tends to be the case with me, it was way to small to do the job I was asking of it. So I started looking for 3pt chippers and found the Chinese 8" jobber. Brand new they go for like $1500. I looked up you tube videos and read up on them and generally, "For what they are", people seemed fairly pleased with them. So when I found one on Craig’s list for $1200, I bought it.

Like a total shmuck, I had the guy try it out for me, but he only had some small twigs to run through it, which is lunched up. I should have known better, and in the back of my mind I knew something was up, but I was pressed for time so we loaded it and away I went. On my first use the other shoe fell. It simply would not chip branches of any diameter. And I ain't talking 8" stuff here, I mean stuff 1.5" to 2.5", stuff that should be right in the "Zone" for this chipper. The guy bought the chipper brand new, ran it till it would not chip anymore and then I bought it. I though about taking it back, but I made the mistake and I decided to live with it. Took it to my tractor guy and they replaced the blades and anvil, greased it, changed the gear oil, and replaced all the belts and adjusted the anvil and knives. I got it back and was ready to GO TO TOWN.

I fired it up and it immediately threw 3 of the 5 main drive belts. I shut it down and wore a grumpy face for the rest of the day.

Now, in no small way, the experience so far has been a lot my fault. I have got $1550 into it so far, $50 more then I could have bought it new for, and I have not run ONE piece of wood through it in the month and a half that I have had it. It's not,,,, easy to work on in any way. Not impossible to work on, but it is a royal pita. That’s why the guy sold it to me, and its why I elected to spend the money to have my tractor guy work on it. I don't know of the more expensive models are any better or worse in this regard, but I can tell the average guy looking for one of these that you have your work cut out for you maintaining it.

Now my question. Anyone have any idea why this tossed belts on start up? Is the tension wrong? Could they have used the incorrect type of belt?

I know the two times I saw it run prior to the belt change that it did in fact run fine, aside from the fact that it would not chip.

I am a bit miffed that the tractor dealer, being the professionals after all, didn't think to try it out prior to sending it back to me. Believe me; this SNAFU is painful for both of us given the 1.5 hour distance between us.
 
1 - 2 of 2 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top