My Tractor Forum banner

1 - 14 of 14 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter · #1 ·
Hi everyone, has anyone experienced or know a fix for no power to forward or reverse and no power to pto, m/c was working fine one minute and when I restarted it wouldn't do the above although the 3pt hitch works and the front loader is ok. Error 06 appeared on the dash so I replaced the MFWD sensor, this hasn't fixed the problem, my next plan of attack is to replace oil and side suction filter, hoping this works as I'm running out of ideas.
When the problem occured there was no catastrophic noise ,smoke or anything that rang alarm bells, engine started fine like it always does it just refuses to move.
 

·
9K+ Poster
Joined
·
12,164 Posts
Welcome to the forum! :Welcome1: Hopefully some of our mechanic members will chime in with easy fixes. :)
 

·
Registered
Joined
·
25 Posts
Hi everyone, has anyone experienced or know a fix for no power to forward or reverse and no power to pto, m/c was working fine one minute and when I restarted it wouldn't do the above although the 3pt hitch works and the front loader is ok. Error 06 appeared on the dash so I replaced the MFWD sensor, this hasn't fixed the problem, my next plan of attack is to replace oil and side suction filter, hoping this works as I'm running out of ideas.
When the problem occured there was no catastrophic noise ,smoke or anything that rang alarm bells, engine started fine like it always does it just refuses to move.
Are you out of warranty? I see you replaced a sensor and it did not fix the problem but you did not specify whether or not the code is still present.
 

·
Registered
Joined
·
7 Posts
Discussion Starter · #5 ·
Hi, Jive Turkey,
The tractor is a 2004 and I'm not the original owner, yes the error code is still showing.
Team Green yes it does have dual pumps that would explain why the loader and 3pt hitch work, I'm still waiting for the technical manual from JD, hopefully this will give me a better idea of the problem.
Thanks, Ian
 

·
Registered
Joined
·
7 Posts
Discussion Starter · #6 ·
Have changed transmission oil and filter, no change in problem, I suspect it's an electrical problem, will have to wait for technical manual.
 

·
Registered
Joined
·
25 Posts
The first two things I would check is the flex plate coupler and the volatge at the fwd and rev solenoids. Because your pto isn't functioning I would check the voltage at the pto solenoid first. If that is all good once you get your manual I would do a charge pump and hydrostatic high pump pressure test.
 

·
Registered
Joined
·
7 Posts
Discussion Starter · #8 ·
Thanks Jive Turkey,
I'm new to all of this and am at a loss where the above are situated on the tractor?
 

·
Registered
Joined
·
1,660 Posts
Hi everyone, has anyone experienced or know a fix for no power to forward or reverse and no power to pto, m/c was working fine one minute and when I restarted it wouldn't do the above although the 3pt hitch works and the front loader is ok. Error 06 appeared on the dash so I replaced the MFWD sensor, this hasn't fixed the problem, my next plan of attack is to replace oil and side suction filter, hoping this works as I'm running out of ideas.
When the problem occured there was no catastrophic noise ,smoke or anything that rang alarm bells, engine started fine like it always does it just refuses to move.
Had this issue last night on a 3320, try pulling the forward/reverse levers back towards you and see if the fault clears....was speaking with one of the delivery guys last night, he suggested it, tried it and sure enough all was ok.
 

·
Registered
Joined
·
7 Posts
Discussion Starter · #13 ·
Jive Turkey, you were on the money, the problem was the flex plate - all four bolts had parted with the fly wheel, luckily I didn't have to split the tractor to replace and torque. A $1.98 fix, plus $180 for the technical manual still it's there for next time.
Thanks for the help all,
Ian
 

·
外人Geezer MTF Member
Joined
·
2,218 Posts
Jive Turkey, you were on the money, the problem was the flex plate - all four bolts had parted with the fly wheel, luckily I didn't have to split the tractor to replace and torque. A $1.98 fix, plus $180 for the technical manual still it's there for next time.
Thanks for the help all,
Ian
Good ending there, ian! I was reading with interest to see how you would fix it - glad to see it wasn't so bad. But, wow, they are a tad proud of those manuals! At least you have one now. It might just save you some money in future.
 
1 - 14 of 14 Posts
Top