My Tractor Forum banner

1 - 20 of 77 Posts

·
Registered
Joined
·
103 Posts
Discussion Starter #1
  1. My neighbor's wife gave me her late husband's 332 JD (1988). I have all the attachments. 50" mid mount deck, plow & material collection system with small engine. Also original receipt and all manuals. It runs great only 947 hours. I already spent approx $800 on rebuilt radiator & hoses for plow. It's rusty faded & 2 hood brackets ripped off needs hood work. Temp gauge & fuel gauge not sure if they work never lit. PTO, mule & plow works. Tires were replaced with weights & chains. I'm not sure if it's worth sinking more money. Your thoughts. Thank you for your input.
 

·
Super Moderator
Joined
·
28,924 Posts
Your were given a great machine and with those accessories worth about $3.5 k. I wouldn't be worried putting more money into it if it's running great.
 

·
Registered
Joined
·
103 Posts
Discussion Starter #3
Thank you, PA318guy My wife was giving me second thoughts. You ease my anxiety.
 

·
Registered
Joined
·
103 Posts
Discussion Starter #5
Ok you convinced me to dive deep into this. When you turn key to the on position what gauges is suppose to light up? I watched another video not sure. The oil,the battery gauges, glow plug and a temperature gauge and fuel gauge light up. After engine is running then they go out? On my tractor, the oil the battery & glow plug gauges light up. glow plug goes on then when it heats up then goes off. The other two stay on the battery & the oil gauges and that's it nothing else lights up. I'm trying to get the fuel gauge and temperature gauge to work correctly. But if it's not broke don't fix it. Thank you for your help. You inspired me to keep it! I do have voltage to the temp wire. Appreciate any information or guide me in the right direction thank you.
 

·
Super Moderator
Joined
·
28,924 Posts
I'm going to move your thread to the JD Garden Tractor Forum, you should have some 332 owners jump in to help, my 322's are the gas version of what you have.
 

·
Registered
Joined
·
103 Posts
Discussion Starter #9
Got it thank you! "All lamps on except for PTO". So I got temperature gauge and fuel gauge out. Maybe it's a blown bulb. PTO pulley engages and switch light works. but this is with no mule attached. The old man could see how to put the mower deck back on but it looks in good shape.
 

·
Super Moderator
Joined
·
28,924 Posts
Well one of the most fun things (satire) you will do is work on keeping the mule drive in place while attaching the deck!! When first doing it remember to loosen the adjuster on the mule drive all the way, this will help to get the belt over the pulley on the deck. I always make sure the belt is over the pulley on the PTO first! It will jump off a few times till you learn how to set things up. If you don't have the front plate on the mule drive which has some instructions on it then here is an image for you, most are missing the cover and sometimes the arm that sticks through, but you should be able to see on the mule drive where the arm should be: (probably some video of the install on youtube, take some time to watch one)


2448137
 

Attachments

·
Registered
Joined
·
937 Posts
The belt installation decal on my mule drives has been loooong gone! I mount the deck to the tractor, then the mule drive, and then the belt. A few turns to snug the belt up, lift the deck full up. Tighten the adjustment knob until both pulleys on the mule are inline...front to back. Locking now at the pto pulley, the belt should be coming straight down onto the mule pulleys. If it's not, wrong belt! Bob
 

·
Parts collector
Joined
·
3,345 Posts
Dang! We want pics! Very nice score!
I have a 332 also and with what I have read they have a tenancy to blow out the voltage regulators. My 332 had the battery light on also, so I got a new VR but have not installed it yet due to the fact that it is not running right now. ? (fuel delivery problems)
You have a great tractor there and for the couple $$$ you may put into it, it is worth it for sure!

Pics and updates please. :)
 

·
Registered
Joined
·
103 Posts
Discussion Starter #13
Trying to figure out this site to upload pictures from my phone not too successful.
 

·
Registered
Joined
·
103 Posts
Discussion Starter #14
Oh by the way the temp gauge and fuel gauge is suppose to be not lit that's normal. I read the operational manual silly me. Temp gauge lights up above 220 F & Fuel gauge lights up low fuel.
 

·
Registered
Joined
·
149 Posts
Dang! We want pics! Very nice score!
I have a 332 also and with what I have read they have a tenancy to blow out the voltage regulators. My 332 had the battery light on also, so I got a new VR but have not installed it yet due to the fact that it is not running right now. ? (fuel delivery problems)
You have a great tractor there and for the couple $$$ you may put into it, it is worth it for sure!

Pics and updates please. :)
I agree you got a **** of a deal. Worth putting some $$$ into. I have a 322 like PA318 guy and it is a tough machine.
 

·
Super Moderator
Joined
·
28,924 Posts
Trying to figure out this site to upload pictures from my phone not too successful.
On your phone you should see a "paper clip" for attaching, this will allow you to take a pic, video (don't hold your breath), and attach a file from the phone.
 

·
Registered
Joined
·
103 Posts
Discussion Starter #17
Thank you all. I welcome the encouragement. I'll try to send some pictures. I took the seat off in the back with the fender that was interesting. I took off the screen cover trans leak cause by loose filter. Is it safe to power wash the dirt off the gas tank and underneath by the trans?
 

·
Super Moderator
Joined
·
28,924 Posts
I wouldn't powerwash the tank, the grommets for the fuel line may pass some water in to the tank. I've used normal hose with easy spray on it. But under it by the trans yes but be careful not to spray where the oil fill tube goes in as it has a vent.
 

·
Registered
Joined
·
103 Posts
Discussion Starter #20
I wouldn't powerwash the tank, the grommets for the fuel line may pass some water in to the tank. I've used normal hose with easy spray on it. But under it by the trans yes but be careful not to spray where the oil fill tube goes in as it has a vent.
Okay thanks I'll just use air compressor that's all.
 
1 - 20 of 77 Posts
Top