My Tractor Forum banner

1 - 11 of 11 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1
I have a 2305 with a 62c and iMatch, when I lift the mower deck, the rock shaft lever remains in the lift position, instead of "kicking out" to the neutral position. My neighbor has the same tractor, and his works as I would expect, when the mower deck is fully lifted, the rock shaft lever returns to the middle position automatically. I made adjustsments to the rock shaft rod that is attached to the lift arms, this didn't seem to make much difference, and I have since returned it to the factory position. Any ideas, this one has be stumped at the moment.
 

·
USMC
Joined
·
19,146 Posts
I haven't ran across that yet. Let us know what you find. slkpk
 

·
Just passing through
Joined
·
8,419 Posts
I have a 2305 with a 62c and iMatch, when I lift the mower deck, the rock shaft lever remains in the lift position, instead of "kicking out" to the neutral position. My neighbor has the same tractor, and his works as I would expect, when the mower deck is fully lifted, the rock shaft lever returns to the middle position automatically. I made adjustsments to the rock shaft rod that is attached to the lift arms, this didn't seem to make much difference, and I have since returned it to the factory position. Any ideas, this one has be stumped at the moment.
Use rockshaft control lever (A) to raise and lower equipment attached to the 3-point hitch.
Lower Implement: Push lever forward. Move lever to neutral position (center) after lowering implement.
Raise Implement: Pull lever rearward. Lever will automatically return to neutral position (center) when implement has fully raised....So...is this occurring?

3-point Hitch Drops Slowly Or Does Not Drop

1. Rate-of-drop valve closed.

2. Rate-of-drop valve set too slowly.
 

·
9K+ Poster
Joined
·
12,161 Posts
It sounds to me like the linkage is adjusted improperly. This is an area the dealer should have looked at. However, the adjustment is quite easy. :)
 

·
Registered
Joined
·
5 Posts
Discussion Starter #8
Thanks for the replies and the service manual screen shot. I have the service manual and adjusted that rod before, but am going to give it another shot. I'll post my findings/solution.
 

·
Registered
Joined
·
5 Posts
Discussion Starter #9
The problem appears to be fixed. I lubricated the adjustment rod and all moving parts connected to the rockshaft lift lever. Nothing appeared to be in a bind, but once I cycled the lever a few times, things started working as expected.

Prior to lubing the adjustment rod, I did change the adjustment rod, as the service manual shows. However, once I made the necessary adjustments, where the rockshaft lever was returning to neutral, my mower deck would only lift about a 1/2 inch. I decided that the adjustment rod should be put back to the factory setting and decided to try some spray lube.

Thanks for suggestions.
 

·
9K+ Poster
Joined
·
12,161 Posts
Easy fixes are the best! :)
 
1 - 11 of 11 Posts
Top