My Tractor Forum banner
  • Are you passionate about Tractors? Would you like to write about topics that interest you and get paid for it? Read all about it here!
1 - 5 of 5 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
Hi,

I'm new here, so hello to all! I just bought a used mower and it has 180 hrs. Everything works like a charm, except the PTO. The clutch itself is good, measured 3.4 Ohm on it. All safety switches are good, tested. Yet, something is messed up. Sometimes the PTO works, then other times it doesn't. I noticed in the shop manual there is a PTO relay located between the battery and the solenoid. Well, in my mower's case it's just not there. There is a fuse there (like the manual says), but the relay isn't there. I'm wondering if Cub Cadet dropped this relay completely, or relocated it without saying anything in the manuals? Could anyone tell me where this relay might be located? In the manual it seems like a 5 prong relay. I've replaced the PTO switch too, so that's not the problem for sure. Thank you for your help in advance! I'm retired and it was enough to pay for the mower ($1850), I can't take it to a shop, just wouldn't fit the bills now.

Best,
Feri
 

·
Super Moderator
Joined
·
9,018 Posts
Moved ya to mid mount ZTR to see if we could drum up some replies
 

·
forkz
Joined
·
6,377 Posts
check seat switch maby bad connection my z force had issues
 

·
Registered
Joined
·
2 Posts
Discussion Starter · #4 ·
Thanks! All the safety switches were good, found the problem: it was the relay, which is located behind the battery, instead of next to it, as the picture suggests in the manual. Replaced it ($10) and all is good now. Thanks again for your response!
 
1 - 5 of 5 Posts
Top