My Tractor Forum banner

2006 New Holland TZ24DA

733 Views 1 Reply 2 Participants Last post by  Gone2dMtns
Hi there, I am new to the site and am learning what it takes to learn and work on larger for me midsize equipment. I recently purchased a 2006 NH TZ24DA w/ a 24hp yanmar diesel. runs great but just recently when throttling up to 540 to engage the mower blades roughly 15 minutes into cutting I begin to loose RPM's and the it will throttle back up and then back down again. This continues until I disengage the mower deck. The tractor does not do this when I am just using with out mowing but I also do not have the RPM up that high either. Any suggestions and/or advice would be greatly appreciated.
1 - 2 of 2 Posts
Try checking the fuel / water separator (filter). Sometimes a simple filter change will resolve this or if there is water in the fuel tank it will need to be bled out. Note that you may have to bleed the line going to the injectors once you crack open the filter. In addition, check your hydraulic fluid level when the system is cold to make sure you have adequate fluid.
Hi there, I am new to the site and am learning what it takes to learn and work on larger for me midsize equipment. I recently purchased a 2006 NH TZ24DA w/ a 24hp yanmar diesel. runs great but just recently when throttling up to 540 to engage the mower blades roughly 15 minutes into cutting I begin to loose RPM's and the it will throttle back up and then back down again. This continues until I disengage the mower deck. The tractor does not do this when I am just using with out mowing but I also do not have the RPM up that high either. Any suggestions and/or advice would be greatly appreciated.
1 - 2 of 2 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top