My Tractor Forum banner
  • Are you passionate about Tractors? Would you like to write about topics that interest you and get paid for it? Read all about it here!
1 - 8 of 8 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
I just bought a 1970 john deere 140 h1 for 200 bucks. The motor is blown Kohler K321AS 14 hp. I have the opportunity to buy a john deere 214 with a 14 hp Kohler K321AQS. Will the work with the 140. Thanks for all your help.
 

·
Registered
Joined
·
776 Posts
An early 214 engine should bolt in. A later 214 engine has mount flanges cast into the block that don't fit between the frame rails of the 140. They can be cut off to make it work.
 

·
Premium Member
Joined
·
1,104 Posts
Kohler K321AQS..........A denotes style of oil pan. Q denotes style of muffler. S denotes electric start. I would think it would bolt right in. May have to change muffler.
 
  • Like
Reactions: MARK (LI)

·
Registered
Joined
·
3 Posts
Discussion Starter · #5 ·
Kohler K321AQS..........A denotes style of oil pan. Q denotes style of muffler. S denotes electric start. I would think it would bolt right in. May have to change muffler.
That's what I was thinking. The guy wants 75 for the motor it has no compression so I'm going to get and throw a rebuild kit in it and let it eat
 

·
Parts collector
Joined
·
4,335 Posts
You might have to bolt the 140 oil pan onto the 214 engine to make it work.
I pulled 16hp (K341) out of a 216 swapped the pan over and dropped it in a 300 and it fit fine.

No compression could just be a stuck valve. That's what was wrong with the 16hp out of the 216. I pulled the head and worked some lube into the guide and wala she was running. Been running for 10 years now with no problems.
The only other problem I could see would be the drive shaft connection on the flywheel. But you can swap that out also.
Heck if you found one you could drop a 16hp K341 in there also. ;)
 

·
Registered
Joined
·
2,142 Posts
No compression could also mean the ACR (Automatic Compression Release) is working! Bob
 
  • Like
Reactions: PA318Guy

·
Registered
Joined
·
3 Posts
Discussion Starter · #8 ·
I pulled 16hp (K341) out of a 216 swapped the pan over and dropped it in a 300 and it fit fine.

No compression could just be a stuck valve. That's what was wrong with the 16hp out of the 216. I pulled the head and worked some lube into the guide and wala she was running. Been running for 10 years now with no problems.
The only other problem I could see would be the drive shaft connection on the flywheel. But you can swap that out also.
Heck if you found one you could drop a 16hp K341 in there also. ;)
Absolutely start with the easy stuff first.
 
1 - 8 of 8 Posts
Top