My Tractor Forum banner
1 - 3 of 3 Posts

· Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
I had the injection pump rebuilt for this 1850 and now no mater what I do I cannot get it to send fuel to the injectors I have even unhooked the lift pump and put a electric pump in its place and that does not help.The shop that rebuilt it said when it was fixed every thing was checked out and was fine.So looking for any ideas or info what I should try next.
 

· Super Moderator
Joined
·
16,931 Posts
Hi kohle 58 and
2476927
...it SEEMS as though it could be one of 2 things...most common after having this stuff apart is a leak somewhere in the line or filter...the other possibility is a clogged fuel line....did you fill up the filter?...if there is a water separator on the line is that filled, with no air bubble in it ( they are usually clear so you cold see that) ? People try getting these diesels going with starting ether I DO NOT recommend that...you can really hear it doing a job in the engine when they do start with ether....I would put some diesel fuel in a spray bottle with a small amount of gasoline and try shooting some into the intake and see if you can at least get it started...you have to be careful with the electric fuel pump that it does not deliver too much fuel
 

· Registered
Joined
·
2 Posts
Discussion Starter · #3 ·
thanks for the reply but i have completly unhooked all the fuel lines to the pump and fuel tank and pulling straight out of a gallon jug and that does not help but I will try the diesel fuel and a little gas
 
1 - 3 of 3 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top