My Tractor Forum banner

Discussions Showcase Albums Media Media Comments Tags Marketplace

1-6 of 6 Results
  1. John Deere Forum
    I replaced the existing carburetor with an inexpensive version. When I put the throttle to choke, it seems it floods and won't start. If I get the throttle adjustment in just the right spot the mower will start, but the engine does surge a bit when running. Has anyone experienced this issue...
  2. John Deere Forum
    I'm trying to get a John Deere LT155 mower back together, and I'm wonder if anyone knows where/what this wire (see attached) goes to?? It was tucked behind the battery and not plugged into anything.
  3. John Deere Forum
    Hey all, I just replaced my drive belt on my LT155. The new belt is kicking off when I hit the brake. I've watched all the videos that show the need to replace the bolt on the idler arm/ tension arm that gets worn and loose causing the belt to kick off. Part #?????? Any help would be...
  4. John Deere Forum
    Hello, Been digging through the forums here to try to find an answer and not sure I found one yet. I have a LT155 and looking to see if there is a snow blower that can be put on it. There are a few used ones that are GX0422X models that appear to work with 100 series, but I'm not sure if that...
  5. John Deere Forum
    I have a JD LT155 I purchased very used! I was hearing a loud grinding coming from underneath and eventually the belt fell off. I noticed the transmission fan extremely bent and rubbing on the belt (which was also loose) throwing it off. Replaced the fan and the belt but now when I engage the...
  6. John Deere Forum
    Long time lurker here who appreciates the depth of knowledge in this community and hopes for a little bit of wisdom. I have a blown Kohler Command CV15S in my LT155 that I need to replace. Last year, I purchased a JD LT155 that appeared to be in pretty good shape. Part of my purchase was...
1-6 of 6 Results
Top