My Tractor Forum banner

Reaction score
0

Profile posts Latest activity Discussions Media Albums About

  • J W Huff ·
    Hi Toolin, I haven't been on for a long time. I have the i1050. I didn't but a snow blade on it. My neighbor does my snow for me. I'll need a little info from you this spring. I enjoy your post very much. Latter Jim
    Skyryder ·
    Thanks again for the help with the i1050 speed problem. I slid under the tractor and examined the idler arm and pulley. I followed your instructions and adjusted the arm to get more tension on the belt. I oiled a few of the linkages and gave it a try. It's hard to tell without the deck on but it does feel better. I need to get 3 new blades before I put on the deck. I'll compare local prices with internet prices. I think I'm 2 or 3 weeks away from my first mowing here in Illinois. -Joe
    J W Huff ·
    Toolin I enjoy your post. The reason I haven't said much is because I,m so busy reading all of your post. Keep them coming. I like my i1050 alot, but I',m not too happy with the way it is built. It's too cheap. I had a Cub 126 and it was built like a tank. It is a shame the way they build things now days. I have had parts fall off, pins drop out and leave linkage handing down. The pin came out of the rod that holds the three rollers on the back of the deck. I never found them. UGH! I saw a video of how cheap the Hydro Trans is made, it makes me nervous. We need to keep up on the maintenance and hope it last. Later. Jim
  • Loading…
  • Loading…
  • Loading…
  • Loading…
  • Loading…
Top