Gravely 5665 Walk Behind - MyTractorForum.com - The Friendliest Tractor Forum and Best Place for Tractor Information
Lawn and Garden Tractor Reviews (All Brands) Share your impressions of your Lawn or Garden Tractor here!

 
LinkBack Thread Tools Display Modes
post #1 of 1 Old 06-14-2019, 11:29 AM Thread Starter
MTF Junior Poster
 
Join Date: Jun 2019
Posts: 2
Gravely 5665 Walk Behind

Hello,
I recently purchased a Gravely 5665 with finishing mower, bushhog and cultivator and a steering sulky and dual wheels. It has the steering brake also. I knew a little history on it and I knew the motor ran good at one point. It has been sitting for awhile since I last saw it run. However I got it running and moved it around some and engaged the blades. I noticed that the high does not work on the hi/lo speed selector on the dash. I adjusted the clutch and noticed that high, when it engages is the same speed as low. It pulls strong, I can pull back on it and it will drag me, but its not "high" speed. The arm down on the axle housing that selects the high low seems to be moving fine.
Any suggestions?
Thanks
John
John Canady is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the MyTractorForum.com - The Friendliest Tractor Forum and Best Place for Tractor Information forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome