Honda GC160 Excell unit - MyTractorForum.com - The Friendliest Tractor Forum and Best Place for Tractor Information
 
LinkBack Thread Tools Display Modes
post #1 of 1 Old 11-04-2017, 11:40 PM Thread Starter
MTF Junior Poster
 
Stihlmill's Avatar
 
Join Date: Nov 2017
Posts: 2
Honda GC160 Excell unit

Hi, I have a few pressure washers and this one in particular has a no name pump with no identification at all. Anyhow, it works perfectly but I happened to take it off to service it, as I bought it used, and when I unbolted it from the motor oil poured out everywhere. The pumps shaft seal is shot and I've tried everywhere I can think of to find the seal for this pump but can't find one anywhere. I can find close but close isn't good enough. I hate to trash it because it needs a seal... I don't have the exact dimensions this second as I have the pumo at work but it's a ridiculous size like I never saw before. I was thinking, what would it hurt if I made a gasket to bolt the pump to the motor and then just filled the pump with oil and the oil leaked past the seal and stopped at the crank of the engine? The crank seal should keep it from entering the motor. I'll just have to put a little extra oil in the pump. If no one agrees with that idea and can't help locate a seal, I'll provide the size tomorrow I promise, what would a good pump replacement be to put on it? I mean a good pump. Not a cheap one that will work for a few times or even a year. A pump that will or should last the life of the machine if properly taken care of. The exact specs on the pressure washer are 2.5 GPM and 2200 psi. I wouldn't be upset it it was bigger than that. I also have a Honda GC190 2.3 GPM 2800psi Kacher unit I bought brand new because it was $280 and never had to use yet because I also have a Honda GX160 Excell unit 2.5 GPM 2400psi with an Annovi Reverberi pump I bought used for $100 and that thing runs and pumps all day but leaks from the pump head and last I checked the oil it was milky so it must be getting some moisture in somewhere but I'm not digging into that one until the other on is fixed even though I have a new one I could use. Any and all help is most appreciated. Thank you.
Stihlmill is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the MyTractorForum.com - The Friendliest Tractor Forum and Best Place for Tractor Information forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome