MyTractorForum.com - The Friendliest Tractor Forum and Best Place for Tractor Information

-   Gravely (https://www.mytractorforum.com/24-gravely/)
-   -   16G fuel pump issues (https://www.mytractorforum.com/24-gravely/862402-16g-fuel-pump-issues.html)

Btackett 08-03-2015 11:06 AM

16G fuel pump issues
 
Ok, got the G back together and went to fire it. Put a little gas in the carb and she started right up for 5 sec. Did it again and again and not seeing fuel coming through inline filter. Removed fuel pump to carb side and turned motor over and nothing coming out. It has sit for about 3 months while restoring process and carb was removed and rebuilt/cleaned. My guess is that the fuel evaporated out of the fuel pump and diaphragm is dry/cracked and not pumping fuel. I have never pulled one of these apart is there a rebuild kit for them on the M18? Anyone ever done one ? She will not run without fuel to the bowl!

thanks!

ATLANTIC CENTRAL 08-03-2015 05:09 PM

Re: 16G fuel pump issues
 
Just buy a new fuel pump. I don't know if anyone has kits, but its not worth the trouble in my view.

They have little rubber flapper check valves in them - they are likely stuck or broken - and yes if it was old, and you let it dry out, the check valves or the diaphragm have now failed.

This is why I don't believe in fuel shut off valves or running engines dry for storage.

Sheldon

beaner2u 08-03-2015 06:41 PM

Re: 16G fuel pump issues
 

Mikey4 08-03-2015 08:27 PM

Re: 16G fuel pump issues
 
I'd never changed a fuel pump on an M18S. When I needed a new one it took me about a half hour. I bought a new supposedly OEM pump on eBay for not a lot of money. The only fiddling was with the fuel line connectors; they fit a variety of M18S flavors so you have to set them for the Gravely application. That took less than 5 minutes. After that, all the time was in removing and replacing the tins and fiddling with the lower mounting screw for the pump. Hard to see with trifocals so it became a matter of (literally) feeling my way through it.

All in all a very doable job.

PA RedRider 08-04-2015 08:22 PM

Re: 16G fuel pump issues
 
I'm about to change my first fuel pump on the Subaru Robin EH65. It has always had cold start issues. The original owner said that he replaced the fuel pump only to find out that his starting issues were related to a fuel filter with too fine filtration. Swapping out the fuel filter solved the issue. My no-start issues, which started about three weeks ago occurred after the machine was sitting for a while (using a 2-wheeler to cut grass mostly). Further investigation yesterday showed that the pump was not pumping when disconnected from the carb. The plastic fuel pump that is on it (Mitsumi brand?) does not appear to be serviceable, so I ordered a new metal OEM one and will be installing it this week.

Btackett 08-06-2015 08:47 AM

Got a new pump ordered and on the way.

PA RedRider 08-15-2015 01:57 PM

Re: 16G fuel pump issues
 
Quote:

Originally Posted by PA RedRider (Post 8163666)
I'm about to change my first fuel pump on the Subaru Robin EH65. It has always had cold start issues. The original owner said that he replaced the fuel pump only to find out that his starting issues were related to a fuel filter with too fine filtration. Swapping out the fuel filter solved the issue. My no-start issues, which started about three weeks ago occurred after the machine was sitting for a while (using a 2-wheeler to cut grass mostly). Further investigation yesterday showed that the pump was not pumping when disconnected from the carb. The plastic fuel pump that is on it (Mitsumi brand?) does not appear to be serviceable, so I ordered a new metal OEM one and will be installing it this week.

Not to hijack this thread, but my new fuel pump arrived today. Installed it and I am getting very sporadic fuel delivery on the output side of the pump. The battery was tired and it had been sitting, so I put it on the tender. Replaced fuel filter. Where to look next? I'm hoping I don't have an issue with crankcase vacuum.

TIA.

ATLANTIC CENTRAL 08-15-2015 02:13 PM

Re: 16G fuel pump issues
 
Quote:

Originally Posted by PA RedRider (Post 8214410)
Not to hijack this thread, but my new fuel pump arrived today. Installed it and I am getting very sporadic fuel delivery on the output side of the pump. The battery was tired and it had been sitting, so I put it on the tender. Replaced fuel filter. Where to look next? I'm hoping I don't have an issue with crankcase vacuum.

TIA.

Have you checked the pickup tube in the tank? I believe it has a screen on it - blow some air back through the line.

Sheldon

PA RedRider 08-15-2015 04:10 PM

Re: 16G fuel pump issues
 
I actually considered that possibility, but never have had any issues with the G-sereis pickup tubes/screens getting clogged. But Eureka, your suggestion worked. I'm now getting significant fuel flow on the output side of the new fuel pump and the tractor roared to life after a couple cranks and about two months of sitting. I probably should have tried this first before springing for a fuel pump, but mine was old and not serviceable. Great suggestion. Thanks for chiming in.:thThumbsU

ATLANTIC CENTRAL 08-15-2015 04:47 PM

Re: 16G fuel pump issues
 
Glad you found the problem, happy to help.

Sheldon

Richard-tx 08-16-2015 01:02 AM

Re: 16G fuel pump issues
 
What I would do is to remove the tank and the valve. Then pressure wash the inside of it. Checkfor any leaks, and reinstall. Ther reason is that the crud that occluded the screen is still in the tank and it will eventually clog it again.

Also get rid of any ethanol fuel and run pure gas. That will keep future corrosion down to a minimum.

ATLANTIC CENTRAL 08-16-2015 09:42 AM

Re: 16G fuel pump issues
 
Quote:

Originally Posted by Richard-tx (Post 8217162)
What I would do is to remove the tank and the valve. Then pressure wash the inside of it. Checkfor any leaks, and reinstall. Ther reason is that the crud that occluded the screen is still in the tank and it will eventually clog it again.

Also get rid of any ethanol fuel and run pure gas. That will keep future corrosion down to a minimum.

Richard, cleaning the tank is a good idea, but like my tractor, his tractor has the top siphon plastic tank, not the metal tank - there is no shutoff valve. I don'y know that a pressure washer would be a good idea with the plastic tank?

And I still don't have all these problems with ethanol fuel everyone talks about?

Sheldon

Richard-tx 08-16-2015 12:09 PM

Re: 16G fuel pump issues
 
Since you have a plastic tank and you don't suck stuff off the bottom, it would be interesting to see if you have some water laying in there and you just don't know it....yet.

My point is that something was blocking the pickup tube. Blowing it back cleared it but whatever blocked it is still in there and it will rear it's ugly head again.

PA RedRider 08-16-2015 01:12 PM

Re: 16G fuel pump issues
 
I've never pulled a G-series tank and done anything with it. Never had the need to. However, I'd consider pulling this one and transferring the contents through a coffee filter and funnel into another container and back just to mitigate future problems. If there's water that might not buy me much.

What I've noticed with this machine, is I can't run the tank down to empty. It will hit the 1/4 mark and begin to act like its empty. I never gave it much thought until now.

EDIT: Maybe we all need one of these Mr. Funnels, which even separates out water.

http://www.amazon.com/Mr-Funnel-AF3CB-Fuel-Filter/dp/B000SOIRCG

Gari 06-19-2019 02:34 PM

Re: 16G fuel pump issues
 
Quote:

Originally Posted by ATLANTIC CENTRAL (Post 8214474)
Have you checked the pickup tube in the tank? I believe it has a screen on it - blow some air back through the line.

Sheldon

Haha, Fantastic. Briiliant!

So simple. After troubleshooting for days, this fixed the problem.

Thank you so much

Gari


All times are GMT -4. The time now is 06:57 AM.

Powered by vBulletin® Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.

vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
User Alert System provided by Advanced User Tagging (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.

 
For the best viewing experience please update your browser to Google Chrome