XT2 stalling under load - MyTractorForum.com - The Friendliest Tractor Forum and Best Place for Tractor Information
Reply
 
LinkBack Thread Tools Display Modes
post #1 of 49 Old 07-27-2019, 07:15 PM Thread Starter
MTF Member
 
Join Date: Sep 2017
Posts: 77
XT2 stalling under load

Cut grass today on my XT2. Grass was a little high and thick. I say grass, but actually weeds. Whenever I'd go through a patch that was thick, the mower would start cutting back and sputtering like it was about to run out of gas. If I turned the mower into a section I'd already cut, it would pick back up, but sputter and want to stall as soon as I got back into the higher grass. When it would start sputtering, I could disengage the blades, it would act like it was about to shut off for a couple of seconds then it would pick up and run at full throttle. This happened about 10 times. I didn't think I was going to get everything finished.

It only happens under load. Disengage the PTO, runs fine. Runs fine with the PTO engaged as long as it is not going through any high and thick spots.

Any ideas as to what the culprit is? I know it could be a myriad of things. It only has 32 hours on it, got it in 2017. I only run ethanol free gas in it.
BowHS is offline  
Sponsored Links
Advertisement
 
post #2 of 49 Old 07-27-2019, 07:43 PM
Proud Member of the 1K Club
 
MARK (LI)'s Avatar
 
Join Date: Apr 2017
Location: LONG ISLAND, NY
Posts: 1,588
Re: XT2 stalling under load

Sounds like a governor problem
MARK (LI) is offline  
post #3 of 49 Old 07-27-2019, 09:50 PM
Proud Member of the 1K Club
 
Join Date: Aug 2016
Location: Northern Florida (Almost Alabama)
Posts: 1,141
Re: XT2 stalling under load

As you said, could be a number of things.
You could be mowing too fast for the grass (weeds) to discharge properly and building up inside the deck. What kind of grass/weeds? Are you mulching? How sharp are the blades? Are you attempting to mow the full width of the deck with each pass? Bagger?
Flaken is online now  
Sponsored Links
Advertisement
 
post #4 of 49 Old 07-28-2019, 12:18 AM
20,000 Posts & Climbing
 
Join Date: Jun 2009
Location: Sault Ste Marie, Ontario
Posts: 21,082
Re: XT2 stalling under load

The grass is packing in around the blades and loading the engine causing the governor to open the throttle wide for more fuel/air mix. The governor WOT position seems to be a bit on the rich side which is causing the spit and sputter when the major portion of the engine's load disappears and the revs come up.

Clean out the grass clippings packing the underside of the deck and reduce the travel speed through the hayfield.

I had the same problem last week when I mowed my neighbour's back lawn for the first time this year. The clippings were oozing out of the chute like tooth paste. I used the manual lift to bang the mower on the walkway bricks to loosen at least some of the grass from the deck. There was quite a pile when I pulled away.

Bob

Click for The Hydraulics Forum!

Sometimes you get on a roll, sometimes the roll gets on you.

In Service
MF GC2310, Husqvarna YTH20B42T

Down for Repairs
MF1655 w/ FEL, MF1655, MF12H, MF8H, MF7H
Spending too much time on MTF to work on my toys.
TUDOR is offline  
post #5 of 49 Old 07-28-2019, 12:21 AM
Proud Member of the 1K Club
 
Steve Urquell's Avatar
 
Join Date: Jun 2018
Posts: 1,692
Re: XT2 stalling under load

I've had this happen with thick, tall, wet grass and dull blades. Sharpened my blades and all was well

2016 Cub XT3 GSE 54" Fab deck, fabbed winch sleeve hitch
2001 Cub 3240 44" deck, fabbed hydraulic sleeve hitch
Steve Urquell is offline  
post #6 of 49 Old 07-28-2019, 10:48 AM Thread Starter
MTF Member
 
Join Date: Sep 2017
Posts: 77
Re: XT2 stalling under load

The blades are sharp, i changed them in May. When it is cutting the grass, it flies out of the chute good and doesn't clump up. I even raised the deck a notch after the blade change seeing how bad the previous blades were.

I don't know what kind of grass/weed it is, it grows to about 6 inches high and has two stems branching off at the tops. It grows so fast and it tends to grow close together and the stems are very tough. It shows up around the first of July and hangs around until the end of the season. The clippings do look like cut hay.

The mower is the XT2 GX54 with the fabricated deck. No bagger. It has run fine all year until yesterday. Well, I say fine, there have been times when I can hear a change when going through a thicker patch of grass. But it was terrible yesterday. And the grass was bone dry, I never cut it when it is wet or damp. Grass is not packed under the deck and I do back off on the speed when going through any high or thick spots.

The oil level is good, not really dirty, and I clean the pre-cleaner on the air filter every second or third cut. I blow off the mower and deck every time I finish cutting with a shop vac or leaf blower.
BowHS is offline  
post #7 of 49 Old 07-28-2019, 11:11 AM
Proud Member of the 1K Club
 
Join Date: Aug 2016
Location: Northern Florida (Almost Alabama)
Posts: 1,141
Re: XT2 stalling under load

Now granted, I have high sand content soil which dulls the blades quickly and usually sharpen after the second mow. So you have been mowing for three months now and haven't sharpened the blades? That could be a problem. If your discharge clippings are looking like cut hay, you are cutting too low. When your grass/weeds are six inches or higher, try the first cut at four inches, then go back over with the cutting height set where you normally mow at.
Flaken is online now  
post #8 of 49 Old 07-28-2019, 11:23 AM Thread Starter
MTF Member
 
Join Date: Sep 2017
Posts: 77
Re: XT2 stalling under load

I do have sandy soil and I know that it dulls the blades. But I checked the blades yesterday, and they look good and still have a good edge on them. When I changed the blades this year, they were cut and notched up pretty bad. I know they were probably in bad shape last year, but it cut all the grass without any problems, no stalling. And like I mentioned, the cutting height was lower last year as well, and no problems.
BowHS is offline  
post #9 of 49 Old 07-28-2019, 11:29 AM
Proud Member of the 1K Club
 
Join Date: Aug 2016
Location: Northern Florida (Almost Alabama)
Posts: 1,141
Re: XT2 stalling under load

Cutting height in inches?
Flaken is online now  
post #10 of 49 Old 07-28-2019, 11:42 AM Thread Starter
MTF Member
 
Join Date: Sep 2017
Posts: 77
Re: XT2 stalling under load

It is in notch 7 out of 12, in the notch below the number 3. So I would say about 2-3/4 to 3 inches, haven't actually measured ground to blade distance, don't have a really level spot to check. High enough to go over some tree roots without the blades hitting them.

Just doing a little research, possible causes include dirt/debris in carb, bad fuel shut-off solenoid, bad coil, bad PTO clutch or switch, etc. etc. Trying to figure out the most likely culprit(s) and go from there. But I did pull each plug wire while it was running (not under load) and could hear a noticeable change in the engine. But I guess it is still possible one of the coils could be overheating or shorting out running under load.

Last edited by BowHS; 07-28-2019 at 01:19 PM.
BowHS is offline  
post #11 of 49 Old 07-28-2019, 01:20 PM
Proud Member of the 1K Club
 
Join Date: Aug 2016
Location: Northern Florida (Almost Alabama)
Posts: 1,141
Re: XT2 stalling under load

OK, in looking at some of your previous posts, this isn't exactly a new issue for you. There is an issue with the SmartChoke by Kohler and a service bulletin was sent out. have you taken it to the dealer since you were mentioning the sputtering and surging last year?
Flaken is online now  
post #12 of 49 Old 07-28-2019, 01:42 PM Thread Starter
MTF Member
 
Join Date: Sep 2017
Posts: 77
Re: XT2 stalling under load

Haven't taken it to dealer, I will have to get them to come pick it up as I have no way of getting it there myself. Guess I will call tomorrow and get them to check it out.
BowHS is offline  
post #13 of 49 Old 07-28-2019, 02:10 PM
Proud Member of the 1K Club
 
Join Date: Aug 2016
Location: Northern Florida (Almost Alabama)
Posts: 1,141
Re: XT2 stalling under load

Write down a list of EVERYTHING you have had problems with. The surging, the sputtering, the problems under load, every tiny little detail. Make a copy of the list and go over everything on your list when you get it back.
Flaken is online now  
post #14 of 49 Old 07-29-2019, 10:52 AM Thread Starter
MTF Member
 
Join Date: Sep 2017
Posts: 77
Re: XT2 stalling under load

Called the dealer, coming by tomorrow evening to pick it up.

Flaken, you may be right about it being the SmartChoke. My sister got a XT2 GX54D last year and had problems this year with it smoking bad, losing power and stalling out going up hills and in high grass. It ended up being the SmartChoke and had to be replaced.

I'm going to mention that when he picks it up (not the same dealer, sister lives a couple hours away). The stalling out trying to cut higher grass along with the surging issues in the past, the SmartChoke is a likely candidate to be the problem. When I get it back I will give an update on what the problem was, may be helpful to others who encounter similar issues.

Thanks to everyone for the help, opinions and advice.
BowHS is offline  
post #15 of 49 Old 08-07-2019, 06:19 PM Thread Starter
MTF Member
 
Join Date: Sep 2017
Posts: 77
Re: XT2 stalling under load

Mower has been at the dealer for a week. Stopped by today to get an update, dealer says he can't find anything wrong with it. He replaced the choke because I had told him of my sister having that be the problem on hers, but he said he didn't think that was the problem, said the one he took off looked fine. No dirt or debris in carb. He let me go a couple a passes with it behind the shop in some high grass, and no problems. Said he ran it for a good 15 minutes or so before changing the choke and checking carb and it didn't miss a beat. He put a new fuel filter and a new air filter on it. Says he is going to try to run it a good 20-30 minutes tomorrow and see if it acts up. If not, he will bring it back tomorrow or Friday.

I asked him about it possibly being fuel solenoid shut-off or a safety switch, he said no, it would completely stop running if it was. He said it possibly could be a coil, but usually if it is it, once it starts acting up, it will continue to. Said it is hard to diagnose when it is running fine and he can't see what it is actually doing.

With my luck, as soon as I get it back, it will start doing the same thing the first time i cut. Probably will run fine until next summer when the warranty runs out.
BowHS is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the MyTractorForum.com - The Friendliest Tractor Forum and Best Place for Tractor Information forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome