Echo SRM-410U Not Running - MyTractorForum.com - The Friendliest Tractor Forum and Best Place for Tractor Information
 
LinkBack Thread Tools Display Modes
post #1 of 8 Old 03-27-2019, 02:38 PM Thread Starter
MTF Member
 
Join Date: Feb 2012
Location: Tennessee
Posts: 56
Echo SRM-410U Not Running

I have an Echo SRM-410U brushcutter. I can get it to run about half throttle with the air filter off but, as soon as I put it on, dies. Also, when it is running, I can get it to surge to full throttle pressing the primer. The moment I let off the throttle, it'll also die. Any idea what's wrong?
Justin E is offline  
Sponsored Links
Advertisement
 
post #2 of 8 Old 03-27-2019, 03:23 PM
Proud Member of the 1K Club
 
Join Date: Apr 2015
Location: British Columbia
Posts: 1,557
Re: Echo SRM-410U Not Running

The carburetor needs a thorough cleaning preferably in an ultrasonic cleaner along with new diaphragms and gaskets. Are you using fresh gas or has it been stored in the shed over winter? Take the numbers off the carb and check online, it may be inexpensive to replace.
RoyM is offline  
post #3 of 8 Old 03-27-2019, 03:28 PM Thread Starter
MTF Member
 
Join Date: Feb 2012
Location: Tennessee
Posts: 56
Quote:
Originally Posted by RoyM View Post
The carburetor needs a thorough cleaning preferably in an ultrasonic cleaner along with new diaphragms and gaskets. Are you using fresh gas or has it been stored in the shed over winter? Take the numbers off the carb and check online, it may be inexpensive to replace.
There was a little in the tank left over. I thought I had drained it. But I run ethanol free with the Red Armoroil that contains stabilizers good for 2 years. I'll try to find a gasket kit.
Justin E is offline  
Sponsored Links
Advertisement
 
post #4 of 8 Old 04-04-2019, 08:09 PM
Senior MTF Member
 
hotajax's Avatar
 
Join Date: May 2009
Location: PA
Posts: 713
Re: Echo SRM-410U Not Running

Justin: May I make a suggestion? Go on ebay and look for a new carb. You can get a new Chinese made carb for $13 or so. I purchased two carbs from "The ROP Shop". They are a vendor on ebay. They have highly quality aftermarket carbs for cheap. Best part - they come with regular screws to adjust the jets, so you don't have to buy any special tools to adjust the carbs. My Echo hedge clipper was doing the same thing. It would start, but no acceleration. $13 bucks later, and a new spark plug, it's running like American Pharoah at the Kentucky Derby. No carb to take apart, no special tools. Just sweetness at high rpm's. Like a brand new tool. Give it a shot and let me know how you make out. A can of fresh premixed 2-cycle fuel is not a bad idea, either. Run the machine with the fresh gas for a few minutes, and it should clean all the crap out of it. I was able to re-use the old gasket that came off the old carb since it had not been cemented in place with Permatex. Time investment? Under one hour, but you'll have a new machine. Hot Ajax.

"I've always been crazy but it's kept me from going insane." -Waylon Jennings
And even worse, I don't care.

Last edited by hotajax; 04-04-2019 at 08:16 PM.
hotajax is offline  
post #5 of 8 Old 04-04-2019, 08:44 PM Thread Starter
MTF Member
 
Join Date: Feb 2012
Location: Tennessee
Posts: 56
My local parts and repair shop gave me the same advice right after I bought the parts to rebuild it. It was a little stubborn to run at first. I had fresh 89 ethanol free fuel with the Echo/Shendaiwa Red Armor oil mixed in. I had to replace the spark plug and air filter as the carb decided to overflow with fuel while I waited for the rebuild kit. After if finally decided to run I added a shot of Marvel Mystery Oil to the tank for good luck. Ran her hard for a little while with food luck.
Justin E is offline  
post #6 of 8 Old 04-04-2019, 08:47 PM
Senior MTF Member
 
hotajax's Avatar
 
Join Date: May 2009
Location: PA
Posts: 713
Re: Echo SRM-410U Not Running

Quote:
Originally Posted by Justin E View Post
My local parts and repair shop gave me the same advice right after I bought the parts to rebuild it. It was a little stubborn to run at first. I had fresh 89 ethanol free fuel with the Echo/Shendaiwa Red Armor oil mixed in. I had to replace the spark plug and air filter as the carb decided to overflow with fuel while I waited for the rebuild kit. After if finally decided to run I added a shot of Marvel Mystery Oil to the tank for good luck. Ran her hard for a little while with food luck.
Marvel Mystery oil is good for everything. I put it in my wife's coffee to keep her quiet all day. I sure do love that stuff.

"I've always been crazy but it's kept me from going insane." -Waylon Jennings
And even worse, I don't care.
hotajax is offline  
post #7 of 8 Old 04-04-2019, 08:50 PM
Senior MTF Member
 
hotajax's Avatar
 
Join Date: May 2009
Location: PA
Posts: 713
Re: Echo SRM-410U Not Running

Here's another tip: Forget about new air filter. Take the air filter out. Take some carb cleaner, and spray the air filter from the inside out. Let it dry, re-install it, and voila. Perfectly good air filter for close to free.

"I've always been crazy but it's kept me from going insane." -Waylon Jennings
And even worse, I don't care.
hotajax is offline  
post #8 of 8 Old 04-05-2019, 10:16 AM Thread Starter
MTF Member
 
Join Date: Feb 2012
Location: Tennessee
Posts: 56
Quote:
Originally Posted by hotajax View Post
Here's another tip: Forget about new air filter. Take the air filter out. Take some carb cleaner, and spray the air filter from the inside out. Let it dry, re-install it, and voila. Perfectly good air filter for close to free.
Don't let your wife find out!

Thanks. They didn't tell me. Then again, that was an excuse to sell me a $17 filter. It's running close to as well as it did brand new. Not bad for something that's about 6 years old.

I'm just glad to have learned a few new things.
Justin E is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the MyTractorForum.com - The Friendliest Tractor Forum and Best Place for Tractor Information forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Echo Clipper Won't Stay Running. Help? hotajax Chippers, Trimmers, Leaf Blowers and Vacuums 1 02-05-2019 04:29 PM
Echo srm 210 ae MoJoMowerman Chippers, Trimmers, Leaf Blowers and Vacuums 0 08-24-2018 07:31 PM
ECHO SRM 210 weed eater bogs down dprcrna Chippers, Trimmers, Leaf Blowers and Vacuums 5 08-11-2018 05:27 PM
Old, well,late 80's Echo SRM 200DB quandry.... Angolagravely Chippers, Trimmers, Leaf Blowers and Vacuums 1 07-17-2018 11:21 AM
ECHO SRM 260, No Spark JamesGarfield Chippers, Trimmers, Leaf Blowers and Vacuums 2 03-12-2013 11:57 PM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome