No power or dash lights x540 - MyTractorForum.com - The Friendliest Tractor Forum and Best Place for Tractor Information
John Deere Forum John Deere Garden Tractor talk

 
LinkBack Thread Tools Display Modes
post #1 of 5 Old 08-24-2019, 10:27 AM Thread Starter
MTF Junior Poster
 
Join Date: Aug 2019
Posts: 4
No power or dash lights x540

My x540 was running and stalled because it was cold. I cranked it again for a few seconds (and it didn't start) then let off. I cranked the starter again too quickly before the engine stopped spinning and everything just died. I have no dash lights, no hour meter, nothing. I put a new ignition switch in......nothing. I took the starter out and bench tested it, it's fine. The four fuses I found are good. I switched the two relays to the right of the steering column (they are both the same type of relay) and nothing changed. The battery is strong. What would kill everything? Does the x540 have a fusible link? Is there any safety switch that would kill my hour meter and dash lights?
Tothna1 is offline  
Sponsored Links
Advertisement
 
post #2 of 5 Old 08-24-2019, 11:57 AM Thread Starter
MTF Junior Poster
 
Join Date: Aug 2019
Posts: 4
After talking to a mechanic at work I think I have a bad ground. I need to check my negative battery cable for resistance when I get home. It looks like it's been replaced before. I wonder if this is a common problem?

I forgot to mention when I check for power at the positive battery terminal using the engine as a ground I show no power with the key on. I do show power with the key off though.
Tothna1 is offline  
post #3 of 5 Old 08-24-2019, 06:44 PM Thread Starter
MTF Junior Poster
 
Join Date: Aug 2019
Posts: 4
Well, just in case anyone has a similar problem, it was the negative battery cable. I figured it out by using a test light. I clipped it to the positive battery terminal. When I touched the negative cable at the battery end I got a light. When I touched the other end of the cable where it bolts to the block, no light.
Tothna1 is offline  
Sponsored Links
Advertisement
 
post #4 of 5 Old 08-24-2019, 07:13 PM
2000 Posts and climbing!!!
 
Join Date: Apr 2016
Location: Alberta
Posts: 2,462
Barn
Re: No power or dash lights x540

thanks for following up and posting what the fix was.
dave_r is online now  
post #5 of 5 Old 08-25-2019, 08:26 AM
2000 Posts and climbing!!!
 
PEIDeerefan's Avatar
 
Join Date: Sep 2008
Location: PEI, Canada
Posts: 2,116
Re: No power or dash lights x540

Thanks for the good info. What year was your x540 and how many hours on it?




2011 John Deere X530 with 48 inch deck
44 inch snowblower, chains, 4 suitcase weights, JD plastic wheel weights
OTC Cab and winter grill cover
2002 John Deere GX345 with 48 inch deck
48 inch John Deere snow blade, 4 suitcase weights and rear tire chains
Power flow bagger
John Deere #80 cart
John Deere 42" lawn sweeper
40 inch Brinly plug aerator
48 inch Brinly lawn roller
PEIDeerefan is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the MyTractorForum.com - The Friendliest Tractor Forum and Best Place for Tractor Information forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome