Jd 5425 - MyTractorForum.com - The Friendliest Tractor Forum and Best Place for Tractor Information
Register Home FAQ Garage MTF Gallery Search Today's Posts Mark Forums Read Store Chat Room

Reply
 
Thread Tools Display Modes
Old 11-23-2008, 12:29 PM   post #1 of 7
bravo
MTF Junior Poster
 
Join Date: Nov 2008
Location: WV
Posts: 4
MTF Member # 20064
Default Jd 5425

I have a JD 5425 that won`t start for the first time. Turn switch on, all dash lights come on and stay on until switch is turned off. This is not normal. Starter does nothing. What are the dash lights telling me? I mean all dash lights come on. This must be some kind of indicator. Thanks
bravo is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 11-23-2008, 12:54 PM   post #2 of 7
skcsbrh
Proud Member of the 1K Club
 
skcsbrh's Avatar
 
Join Date: Sep 2008
Location: NE Indiana
Posts: 1,124
MTF Member # 18268
Images: 10
Default Re: Jd 5425

Sounds like it could be the ignition switch.
__________________
A Day Inport Is Like A Day Without Sunshine!
USS TULLIBEE (SSN-597), USS FULTON (AS-11), USS PAIUTE (ATF-159), USS BAINBRIDGE (CGN-25), USS ASHLAND (LSD-48), USS GRAPPLE (ARS-53) Naval Station Guam, US Forces Carribean Key West FL, EOD Group Two VA, Allied Command Atlantic (NATO), VA.
skcsbrh is offline   Reply With Quote Quick reply to this message
Old 11-23-2008, 09:10 PM   post #3 of 7
jd110
Senior MTF Member
 
jd110's Avatar
 
Join Date: Jul 2007
Location: Carroll County, MD
Posts: 941
MTF Member # 6718
Default Re: Jd 5425

Have you tried to jump-start it? Sometimes low voltage can cause the instrument panel to not complete it's bulb check. I would suspect a bad battery, cable, or dirty connection. Also be sure that neutral switches on transmission and pto are in neutral. Does the starter click at all? Is this a reverser or sync shift? Is it a cab tractor or open station?
jd110 is offline   Reply With Quote Quick reply to this message
Old 11-24-2008, 02:34 PM   post #4 of 7
bravo
MTF Junior Poster
 
Join Date: Nov 2008
Location: WV
Posts: 4
MTF Member # 20064
Default Re: Jd 5425

My JD 5425 is open station, sync shift. I have not tried to jump start it. The battery seems to be OK. I did a slow 12hr. charge on it. I have not had any trouble starting the engine in the past, but the weather has gotten cold. In the thirty`s here, so the battery could be weak. There is no click, chatter, nothing at all that would indicate the starter is trying to kick in. Normal starting is when I turn the switch on, 4 beeps, gauges check, and I start the engine. Now I turn switch on all dash lights come on including signal directional arrows(not blinking) instrument panel illumination, indicator lights, and gauges, no beeps. I turn switch to start and nothing. The dash panel lighting up like this must be telling me something, but I don`t know what. It is possible it is the battery. Tractor has 540hrs. and is a 2005. Thanks for any help you can give me. All switches in neutral (PTO, Trans.), Cleaned battery terminals. ???????
bravo is offline   Reply With Quote Quick reply to this message
Old 11-25-2008, 06:49 AM   post #5 of 7
Upper5Percent
5000 Strong & Climbing
 
Upper5Percent's Avatar
 
Join Date: Dec 2007
Location: USofA
Posts: 7,320
MTF Member # 8602
Default Re: Jd 5425

I would have your battery tested...

Here are your manuals online...

http://manuals.deere.com/omview/OMRE260579_19/?tM=

http://manuals.deere.com/omview/OMRE260580_19/?tM=
__________________
The answer is 42
Upper5Percent is offline   Reply With Quote Quick reply to this message
Old 11-25-2008, 12:56 PM   post #6 of 7
bravo
MTF Junior Poster
 
Join Date: Nov 2008
Location: WV
Posts: 4
MTF Member # 20064
Default Re: Jd 5425

Paul, I had the battery tested today, it tested good. Thanks for the manuals. I did not know there is a fuse link at the battery. I will check this and hook up the battery and see what I can find. Thanks again.
bravo is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 11-25-2008, 05:42 PM   post #7 of 7
bravo
MTF Junior Poster
 
Join Date: Nov 2008
Location: WV
Posts: 4
MTF Member # 20064
Default Re: Jd 5425

The fuse was good. I put the battery back in the JD, turned switch on, all was normal, hit start and she fired up. I don`t know what was wrong. She cured her self, so I`m a little nervous about that, but glad its running. Is it possible that something reset when I disconnected the battery, I don`t know. Anyway just letting you know what happened. Thanks to all for trying to help.
bravo is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the MyTractorForum.com - The Friendliest Tractor Forum and Best Place for Tractor Information forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 10:59 PM.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.
Compact Tractor Reviews Tractor Reviews Snowblowers Lawn Mower Forum
My Tractor Forum Snow Thrower Power Equipment Forum
Combine Forum Snowblower Forum ATV and UTV Reviews