Jd 5425 - MyTractorForum.com - The Friendliest Tractor Forum and Best Place for Tractor Information
 
Thread Tools Display Modes
post #1 of 7 Old 11-23-2008, 01:29 PM Thread Starter
MTF Junior Poster
 
Join Date: Nov 2008
Location: WV
Posts: 4
Jd 5425

I have a JD 5425 that won`t start for the first time. Turn switch on, all dash lights come on and stay on until switch is turned off. This is not normal. Starter does nothing. What are the dash lights telling me? I mean all dash lights come on. This must be some kind of indicator. Thanks
bravo is offline  
Sponsored Links
Advertisement
 
post #2 of 7 Old 11-23-2008, 01:54 PM
Proud Member of the 1K Club
 
skcsbrh's Avatar
 
Join Date: Sep 2008
Location: NE Indiana
Posts: 1,124
Images: 10
Re: Jd 5425

Sounds like it could be the ignition switch.

A Day Inport Is Like A Day Without Sunshine!
USS TULLIBEE (SSN-597), USS FULTON (AS-11), USS PAIUTE (ATF-159), USS BAINBRIDGE (CGN-25), USS ASHLAND (LSD-48), USS GRAPPLE (ARS-53) Naval Station Guam, US Forces Carribean Key West FL, EOD Group Two VA, Allied Command Atlantic (NATO), VA.
skcsbrh is offline  
post #3 of 7 Old 11-23-2008, 10:10 PM
Proud Member of the 1K Club
 
jd110's Avatar
 
Join Date: Jul 2007
Location: Carroll County, MD
Posts: 1,071
Re: Jd 5425

Have you tried to jump-start it? Sometimes low voltage can cause the instrument panel to not complete it's bulb check. I would suspect a bad battery, cable, or dirty connection. Also be sure that neutral switches on transmission and pto are in neutral. Does the starter click at all? Is this a reverser or sync shift? Is it a cab tractor or open station?
jd110 is offline  
post #4 of 7 Old 11-24-2008, 03:34 PM Thread Starter
MTF Junior Poster
 
Join Date: Nov 2008
Location: WV
Posts: 4
Re: Jd 5425

My JD 5425 is open station, sync shift. I have not tried to jump start it. The battery seems to be OK. I did a slow 12hr. charge on it. I have not had any trouble starting the engine in the past, but the weather has gotten cold. In the thirty`s here, so the battery could be weak. There is no click, chatter, nothing at all that would indicate the starter is trying to kick in. Normal starting is when I turn the switch on, 4 beeps, gauges check, and I start the engine. Now I turn switch on all dash lights come on including signal directional arrows(not blinking) instrument panel illumination, indicator lights, and gauges, no beeps. I turn switch to start and nothing. The dash panel lighting up like this must be telling me something, but I don`t know what. It is possible it is the battery. Tractor has 540hrs. and is a 2005. Thanks for any help you can give me. All switches in neutral (PTO, Trans.), Cleaned battery terminals. ???????
bravo is offline  
post #5 of 7 Old 11-25-2008, 07:49 AM
Just passing through
 
Upper5Percent's Avatar
 
Join Date: Dec 2007
Location: VT, OH & ND
Posts: 8,340
Re: Jd 5425

I would have your battery tested...

Here are your manuals online...

http://manuals.deere.com/omview/OMRE260579_19/?tM=

http://manuals.deere.com/omview/OMRE260580_19/?tM=

"You know, farming looks mighty easy when your plow is a pencil, and you're a thousand miles from the corn field."
DWIGHT D. EISENHOWER
Address at Bradley University, Peoria, Illinois, 9/25/56
Upper5Percent is offline  
post #6 of 7 Old 11-25-2008, 01:56 PM Thread Starter
MTF Junior Poster
 
Join Date: Nov 2008
Location: WV
Posts: 4
Re: Jd 5425

Paul, I had the battery tested today, it tested good. Thanks for the manuals. I did not know there is a fuse link at the battery. I will check this and hook up the battery and see what I can find. Thanks again.
bravo is offline  
post #7 of 7 Old 11-25-2008, 06:42 PM Thread Starter
MTF Junior Poster
 
Join Date: Nov 2008
Location: WV
Posts: 4
Re: Jd 5425

The fuse was good. I put the battery back in the JD, turned switch on, all was normal, hit start and she fired up. I don`t know what was wrong. She cured her self, so I`m a little nervous about that, but glad its running. Is it possible that something reset when I disconnected the battery, I don`t know. Anyway just letting you know what happened. Thanks to all for trying to help.
bravo is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the MyTractorForum.com - The Friendliest Tractor Forum and Best Place for Tractor Information forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome